iTunes 10.5 mit extrem hoher CPU-Last (Gelöst)

Ich habe gestern auf iTunes 10.5 aktualisiert und muss nun feststellen, dass einige Prozesse nun eine sehr hohe CPU-Last verursachen. Ich verwende Windows 7 (32 bit).

Die Prozesse mit hoher CPU-Last sind:

  • APSDaemon.exe
  • AppleMobileDeviceService.exe
  • MDCrashReportTool.exe

In Summe verursachen die Prozesse eine CPU-Last von 100%.

Wenn ich iTunes starte, dann wird APSDaemon.exe auch gestartet und hat dann eine CPU-Last von um die 50%. Wenn ich mir den Prozess mit dem Sysinternals Process Explorer anschaue, stelle ich fest, dass die hohe CPU-Last von einem Unterprozess (Thread) namens MSVCR80.dll kommt. MSVCR80.dll ist die Microsoft Visual C Runtime.

iTunes 10.5 - APSDaemon.exe (Threads)

iTunes 10.5 - APSDaemon.exe (Threads)

Wenn ich nun das iPhone anschließe, dann beginnt der Prozess AppleMobileDeviceService.exe durchzudrehen. Hierbei handelt es sich um einen Systemdienst, der die Verbindung zwischen iTunes und iPhone herstellt.
Auch hier ist wieder die Datei MSVCR80.dll beteiligt.

iTunes 10.5 - AppleMobileDeviceService.exe (Threads)

iTunes 10.5 - AppleMobileDeviceService.exe (Threads)

Fange ich nun noch an tatsächlich zu synchronisieren, dann wird der Prozess MDCrashReportTool.exe gestartet, der genau das gleiche Problem hat wie die beiden vorherigen Prozesse auch.

iTunes 10.5 - MDCrashReportTool.exe (Threads)

iTunes 10.5 - MDCrashReportTool.exe (Threads)

Letzten Endes friert dann noch iTunes ein und ich muss die Prozesse alle von Hand beenden.

Ich habe absolut keine Ahnung wie ich das Problem beheben kann. Weder bei Apple noch über Google finde ich eine konkrete Problemlösung. Aber es gibt einige Seiten wo über dieses Problem mehr oder weniger detailliert berichtet wird. Eine Lösung ist mir da aber auch nicht über den Weg gelaufen. (iTunes CPU Hog on Windows 7 64 bit)

Hat irgendjemand die gleichen Erfahrungen gemacht und kann mir helfen das Problem zu lösen? Removing and reinstalling iTunes, QuickTime, and other software components for Windows Vista or Windows 7 habe ich bereits zweimal durchgeführt.

1. Update: Die Deinstallation von Panda Cloud Office Protection hat bei mir geholfen. Alle oben aufgeführten Symptome sind verschwunden. Man sollte also mal in Betracht ziehen testweise den Virenscanner zu deinstallieren.

2. Update: Die Neuinstallation von Panda Cloud Office Protection führt sofort wieder zu dem oben genannten Problem. Ich werde nun einen Call bei Panda eröffnen und über das Ergebnis hier wieder berichten. In der Zwischenzeit wäre es vielleicht sinnvoll einen anderen Virenscanner zu installieren. Vielleicht Microsoft Security Essentials als kostenlose Alternative bis das Problem endgültig gelöst ist.

3. Update: Ich habe nun einen Call bei Panda eröffnet und ein paar Hausaufgaben mit auf den Weg bekommen. Diese werde ich heute Abend erstmal erledigen und dann sehen wir weiter.

4. Update: Die mir von Panda aufgetragenen Hausaufgaben habe ich nun erledigt und meine Erkenntnisse per E-Mail eingereicht. Ich konnte herausfinden, dass wenn ich die Datei %programfiles%\\Panda Security\\WAC\\PavLSP.dll umbenenne und dann den Rechner neu starte das Problem nicht mehr auftritt. Allerdings ist dann auch keine DNS-Auflösung mehr möglich und dadurch die gesamte Netzwerk-/Internetkommunikation gestört. Kann jemand meine Erkenntnisse bei sich nachvollziehen und bestätigen?

5. Update: Panda hat sich bei mir mit einem Lösungsversuch gemeldet. Ich sollte die mitgesendete Datei WebExper.dat in das Verzeichnis %programfiles%\\Panda Security\\WAC kopieren und danach den Rechner neu starten. In der Datei wurden Ausschlüsse in Bezug auf iTunes eingetragen. Leider hat dies auch nicht zum Erfolg geführt.

6. Update: Panda hat sich erneut bei mir mit einem Lösungsversuch gemeldet. Dieses Mal wurde eine neue Datei WebExper.dat gesendet, welche ich erneut in das Verzeichnis %programfiles%\\Panda Security\\WAC kopieren sollte. Auch dies hat nicht geholfen.

Gelöst: Panda konnte jetzt die Datei WebExper.dat so anpassen, dass es zu keinen Problemen in Verbindung mit iTunes und PhotoStream mehr kommt. Panda hat mir zugesagt, dass die Änderungen in das nächste Update einfließen wird.

30 Gedanken zu „iTunes 10.5 mit extrem hoher CPU-Last (Gelöst)

  1. Danke,

    netsh winsock reset

    hat geholfen, hat schon mal bei einem Netzwerkproblem geholfen.
    Man muss nat. 2 mal sichern, da beim ersten mal die Trojaner von Apple auf dem Pad gefunden werden, oder man schaltet die Firewall aus.

    Gruß Herbert

  2. Zumindest bei Sophos ist es die endpoint firewall.

    die prozesse applemobiledeviceservices, apsdaemon.exe und ituneshelper haben eine neue checksumme, wen wundert es … sind ja auch neue Versionen.
    Der Virenscanner bring seine endpoint protection mit, hat die alten checksummen gelenrt und die upgedateten programme werden geblockt (drop = udp timeout = bis dahin warten auf den anderen prozess der nicht antwortet = wir beschaeftigen mal prophylakitsch die cpu).
    Also, die applikationen wieder getrustet (update der checksummen), dann udp nach 127.0.0.1 erlaubt und itunes konnte wieder mit sich selbst reden.
    Warum machen die das eigentlich ueber den Netzwerkstack und nicht ueber einen anderen Socket im System?

    Viele Gruesse
    Bommelmuetze

  3. Hallo!

    es scheint die Firewall zu sein, der applemobiledeviceservice versucht mit sich selbst via udp zu reden und der appsdaemon versucht das netz 17.172.232.0/24 nach irgendwas zu durchforsten.

    Vielleicht sucht er mama icloud.
    Name: st11p01st-courier047-bz.push.apple.com
    Address: 17.172.232.97

    Also Virenscanner allein ist OK, USB Devicecontrolle ist an und macht auch keine Probleme.
    Und zu guter letzt kommt die gute alte Firewall …

    lasst mal die prozesse ituneshelper, applemobiledeviceservice und diese komische exe da per udp auf 127.0.0.1 unterhalten.
    Dann klappts auch wieder.
    Und dann sollten die Penner die das programmiert haben mal lernen sauber zu coden.
    Und die Penner vom Apple-Support sollten mal ordentlich dokumentieren, nicht nur fuer typische Appleuser, sondern auch fuer untypische.

    Viele gruesse
    Jochen

  4. Werde ich mal testen… Mir hat man eine Binärdatei geschickt, die vermutlich irgendein Verhalten von Panda modifiziert. Damit läuft die Applemobiledeviceservice.exe wieder normal und die Synchronisation klappt auch, allerdings hatte ich zwischenzeitlich Sync-Fehler und die APSDaemon.exe läuft nach Start von iTunes trotzdem mit voller Core-Last. Ansonsten aber keine offensichtlich negativen Auswirkungen. Ausser: Ich meine, dass Itunes bislang beim Anschluss des iPhones automatisch startete, dies funktioniert jetzt nicht mehr. Kann das an irgendeinem neuen Setting liegen?
    Fazit ansonsten: abwarten, was Panda noch dazu beizutragen hat…

    • Beim googlen fand ich hier den helfenden Hinweis:
      netsh winsock reset

      in einem DOS-Fenster eingeben und mit Enter bestätigen. Bei Windows 7 muss das Eingabefenster mit Administratorrechten geöffnet werden. Dazu über „Alle Programme->Zubehör->Eingabeaufforderung“ mit der rechten Maustaste klicken und auf „Als Administrator ausführen“ klicken. Nach der Eingabe den Rechner neu booten. Dadurch wird der Windows TCP/IP Stack gelöscht und der Rechner soll auch etwas schneller booten. Jetztklappt der Backup im Itunes und iOS5 kann installiert werden.

      Seither funktioniert der Store und alles Andere wieder. :-)

      • In meinem konkreten Fall hilft das wie bereits mehrfach beschrieben leider nicht. Es handelt sich um ein Problem zwischen iTunes und Panda (Virenscanner).

      • Hallo, ich habe mir Panda zu Testzwecken installiert, war aber nicht zu frieden und habe es wieder deinstalliert. Trotzdem zeigte mein PC oben genanntes Problem. Ich habe schon gedacht, ich kriege die Krise. Der Hinweis auf „netsh winsock reset“ hat das Schlimmste verhindert. Seit der Ausführung wie beschrieben tritt das Problem nicht mehr auf; Win XP + SP 3. Gruß

      • Vielen Dank für diesen Tipp. Nach wochenlangem und erfolglosem Suchen, Recherchieren und „Haare raufen“ kann ich mein iPhone endlich wieder Sichern und Synchronisieren.
        Vor lauter Verzweiflung hatte ich sogar schon angefangen, die Meldungen der Console mitzulesen …

  5. ich würde sagen, mal auf den panda support warten :P ich habe nicht vor die office protection wg. nem itunes update runterzuwerfen. nein danke.

  6. Im Zusammenhang mit der MSVCR80.dll als „Schuldigen“ ist interessant, dass Microsoft diese nicht mehr als Systemdatei deklariert, sondern erwartet, dass jedes Programm seine „eigene“ MSVCR80 in seinen eigenen Ordnern mitbringt (KB 326922). Zumindest auf meinem System (WinXP SP3) gibt es diese DLL aber nirgendwo in den „Apple-Ordnern“ (iTunes, Gemeinsame Dateien\Apple,…), sondern nur in Ordnern von ein paar Programmen (u.a. auch beim Virenscanner) und in mehreren Ordnern „Windows\WINSXS“. Könnte das evtl. einen Konflikt hervorrufen?
    Ich habe schon versucht, einfach irgendeine MSVCR80 in die jeweiligen Apple-Ordner zu kopieren – erfolglos.

  7. ich habe genau das gleiche problem wie m3d1c5, allerdings konnte leider bislang noch keiner der tipps helfen :(

    anmerkung: ich benutzte auch panda cloud office protection ;)

  8. Die Deinstallation von Panda Cloud Office Protection hat bei mir geholfen. Alle oben aufgeführten Symptome sind verschwunden. Man sollte also mal in Betracht ziehen testweise den Virenscanner zu deinstallieren.

    • Ich habe zufällig ebenfalls Panda und das selbe Problem. Nachdem ich Panda deinstalliert habe, funzt es endlich und das Backup vor der Installation von iOS5 auf meinem iPhone läuft nun endlich, ohne wegen der CPU-Auslastung hängen zu bleiben. 1000 Dank für den Tipp, den ich schon seit 2 Tagen suche!!!! Aber was mache ich nun mit Panda? Habe da ein Abo für 10 Rechner und 2 davon nutze ich mit dem Problem!

      • Hallo Tommy, ich werde nun erstmal versuchen wie sich das ganze verhält, wenn ich Panda jetzt neu installiere. Treten die Probleme wieder auf, dann werde ich bei Panda einen Call dazu eröffnen. Ich habe telefonischen Support bei denen. Meine Ergebnisse teile ich dann hier wieder mit.

        • So, eine Neuinstallation von Panda Cloud Office Protection führt dazu, dass die gleichen Probleme wieder auftreten. Ich werde nun bei Panda einen Call eröffnen und hier das Ergebnis berichten.

          • Hallo zusammen, hier ein paar Infos von meiner Seite:
            Ich habe mit dem Panda for Business (aktuelle Version 4.50.00) das gleiche Problem seit iTunes 10.4. Ein Downgrade auf iTunes 10.3 oder ein Abschalten von Panda führt dazu, dass der MobileDeviceService, bzw. mit 10.5 auch der APSDaemon wieder richtig laufen. Ein bloßes Ausschliessen der „Apple-Verzeichnisse“ aus dem Viren-Scanner bringt nichts. Ich habe das auch schon so an Panda weitergereicht, ich weiß aber nicht, ob wirklich Panda der Verursacher ist (-> siehe meinen Kommentar zur MSVCR80).

  9. Hi Andreas!

    Dein Tip hat geholfen – super klasse! (Wie kommt man bloss auf sowas?)
    Ich probiere jetzt schon 2 Tage an dem Mist rum, aber daran hätte ich echt nicht gedacht. Was ein lokales Backup zudem mit dem Netzwerk zu tun hat bleibt mir ein Rätsel.

    Ein weiterer Vorteil ist nun, dass alle Netzerkverbindungen an meinem PC jetzt etwas zügiger laufen :-) Vielleicht sollte man den Befehl öfter mal ausführen um Probleme zu vermeiden?

    Danke nochmal!

    Gruß
    Techno

  10. Hallo zusammen,
    vollständiges deinstallieren sowie erneutes installieren klappte bei mir bei iTunes 10.4, leider aber nicht bei iTunes 10.5.

    Der Tipp auf dieser Seite tat es dann aber und war deutlich unkomplizierter:
    http://www.thebambers.me.uk/wordpress/
    Reseten des TCP(IP-Stacks.

    Viel Erfolg!

  11. Idee: Ich teste heute mal meine Spyware Doctor zu deinstallieren. Scheinbar macht der oft Probleme. Habt Ihr solch ein programm installiert?

  12. Hallo,

    hat bei mir auch nicht geklappt (Windows 7 64bit). Langsam verliere ich die Nerven.
    Es muss doch eine Erklärung geben.
    Itunes 10.3 funktioniert noch. Wenn ich dann auf 10.4 oder 10.5 update ist das Problem da. Kein Store und 100% Cpu. Nix geht mehr.Auch wenn ich Icloud Systemsteuerung starte hab ich das Problem.
    Bei mir sind es die Itunes.exe mit 50% und diese APSDaemon.exe mit ca.50%. HILFEEEEEEEEEEEEE

Kommentare sind geschlossen.